let
  emacsPrime = (pkgs.emacs.override {
    srcRepo = true;
    withGTK2 = false;
    withGTK3 = false; # GTK3 Emacs isn't wayland-native, it just adds the gtk bug https://emacshorrors.com/posts/psa-emacs-is-not-a-proper-gtk-application.html
      }).overrideAttrs ({name, version, ...}: {
        name = "emacs-${version}-thblt";
        version = "27.1";
        src = builtins.fetchGit {
          url = "git://git.savannah.gnu.org/emacs.git";
          rev = "86d8d76aa36037184db0b2897c434cdaab1a9ae8";
        };
        autoconf = true;
        automake = true;
        texinfo = true;
        patches = [];
      });